BetterUp - Degraded AI experience – Incident details

All systems operational

Degraded AI experience

Resolved
Degraded performance
Started about 2 months agoLasted about 15 hours

Affected

BetterUp Platform

Degraded performance from 8:00 AM to 11:07 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Our Cloud Provider has provided updates that their services are nearly back to fully operational. We expect to see less disruption to BetterUp systems, and will close this incident when the underlying Provider has fully recovered.

  • Investigating
    Investigating

    BetterUp is currently experiencing issues with our Cloud Provider. We're monitoring for updates. For now, this may negatively impact experiences across the BetterUp platform. We'll update here as our provider works to resolve issues in their systems.